Author Topic: NAV VI Ghosting  (Read 357 times)

0 Members and 1 Guest are viewing this topic.

OnlineCasbar

  • Hero Member
  • *****
  • Posts: 2,304
  • Country: gb
    • Model/year: R1250RT 2019
    NAV VI Ghosting
    « on: 2021-02-16 17:54:00 »
    There have been loads of posts on other forums about the Nav VI fault called Ghosting. Well mine started to do this in October. I cleaned the screen and all seemed well, haven't used it much as all our blood bikes have their own sat nav. Anyway yesterday I took my Nav VI along on a couple of jobs. After one pickup i went into categories to find a Hospital and the screen went mad, just flipping all over the place. Which is why they call it ghosting, it's like someone with pushing the screen and making the Nav change screens on its own. So I phoned Garmin as my Nav is around 3 years old. They asked me some questions and confirmed they knew about the issue on some Navs and there is now a fix, so new units should be ok. Options, were, buy a new one or pay them £145 and they will replace with a new refurbished Nav VI that is fixed. So that is the option I took, also had to pay £35 postage for recorded and insured delivery, even though I am only 18 miles from their HQ in Southampton and where the device was going. But computer says no drop off because of Covid and they have to put all incoming devices into quarantine for at least 3 days :)  They also told me my unit was made in 2017, even though I have only bought it from a BMW dealer just under 3 years ago.
    « Last Edit: 2021-02-16 17:55:37 by Casbar »

    OfflineBlackrat

    • Newbie
    • *
    • Posts: 8
    • Country: gb
      • Model/year: 2014rtlc
      Re: NAV VI Ghosting
      « Reply #1 on: 2021-03-18 08:04:02 »
      I'm currently on my fourth nav iv, the original one bought dec 17, all for ghosting. The third unit lasted the longest, just under two years, and was replaced foc a couple of weeks ago. Hopefully this one will last. My wife's bike has the nav v which has been far more reliable so if I have any further issues I may well source one of those. Or I could always bite the bullet on a new RT... :)
      Gary

      OnlineCasbar

      • Hero Member
      • *****
      • Posts: 2,304
      • Country: gb
        • Model/year: R1250RT 2019
        Re: NAV VI Ghosting
        « Reply #2 on: 2021-03-18 09:18:50 »
        My Nav V was rock solid for years as well

        OfflineOld-Git

        • Full Member
        • ***
        • Posts: 240
        • Country: gb
          • Model/year: R1200RT LE 2015
          Re: NAV VI Ghosting
          « Reply #3 on: 2021-05-03 10:36:04 »
          My Nav 6 is nearly 4 years old and has been flawless, up until now. When I use the Tracks that I have imported (from myrouteapp gold, saved as GPX 1.0) I'm getting ghosting, it moves to the next screen on it's own. I stop the track, set a single destination and it works fine..... ??? I'll try gpx 1.1 next time, see if that fixes it, or perhaps it's the new software version that I installed the oither day...?

          OnlineCasbar

          • Hero Member
          • *****
          • Posts: 2,304
          • Country: gb
            • Model/year: R1250RT 2019
            Re: NAV VI Ghosting
            « Reply #4 on: 2021-05-03 12:43:20 »
            Mine started when I was following an imported route but then when I picked a location from one of the loaded routes, I was trying to nav to a hospital. There used to be a problem with MRA gpx 1.1, you used to have to mess around with it in the Nav or you ended up with a straight line route, not sure if this was ever fixed. I only use 1.0 and then change waypoints to shaping points in the device itself.