What am I doing wrong, Nav 5

Having problems with the BMW Navigator V VI or the TFT display?
User avatar
PhilMill
Posts: 35
Joined: Tue Aug 28, 2018 9:37 pm

What am I doing wrong, Nav 5

Post by PhilMill »

Hi Guys, so the new RT arrived on Friday, I've had a great weekend on her, need to get the miles on ready to get the first service out of the way. Anyway, I fitted may Nav 5 and I cant get it do do anything on the Wonderwheel, it won't zoom or change pages, all it does is turns off, all other functions on the RT's display do nothing. What am i doing wrong here please?


Thanks, Phil.
Too many bikes, not enough time!
gogs01
Posts: 628
Joined: Mon Jan 12, 2015 8:32 am

Re: What am I doing wrong, Nav 5

Post by gogs01 »

Not sure this helps, but my Nav 5 works with my wonderwheel, so I'm sure yours will too.
Unfortunately, I don't know enough to help you get yours working.
I'm sure somebody smarter will be along directly .....
My 4th R1200RT = 2016 (2017 MY) R1200RT LE
LAF
Posts: 186
Joined: Mon Dec 12, 2016 11:33 pm

Re: What am I doing wrong, Nav 5

Post by LAF »

PhilMill wrote: Hi Guys, so the new RT arrived on Friday, I've had a great weekend on her, need to get the miles on ready to get the first service out of the way. Anyway, I fitted may Nav 5 and I cant get it do do anything on the Wonderwheel, it won't zoom or change pages, all it does is turns off, all other functions on the RT's display do nothing. What am i doing wrong here please?


Thanks, Phil.
Have you tried to update it?
Is it in motorcycle mode?
Sethmopp
Posts: 13
Joined: Wed May 30, 2018 9:22 pm

Re: What am I doing wrong, Nav 5

Post by Sethmopp »

Apparently it doesn't have the connectivity on the RT that it does on the GS, however, if you have the audio package fitted then it does seem to work. I don't have the audio on mine so lost connectivity.
TJRL
Posts: 115
Joined: Wed Nov 11, 2015 1:00 pm
Has liked: 4 times
Been liked: 2 times
United States of America

Re: What am I doing wrong, Nav 5

Post by TJRL »

The Nav V from my 2015RT worked straight away on my July 2018 RT, both bikes had the BMW audio systems fitted from the factory. I think that without the audio system you have asked for the "audio preparation including GPS", but as I had the audio factory fitted I am not certain on this point.
2020 R1250RT, 2021 Triton ST-125, 1960 SII Land Rover.
User avatar
Beagle
Posts: 582
Joined: Mon Jul 16, 2018 7:42 pm

Re: What am I doing wrong, Nav 5

Post by Beagle »

Taken from manual,


" Special functions
with preparation for navigation system OE
Integration of the BMW Motorrad Navigator V can result in devi- ations from the descriptions in the operating instructions for the Navigator "
   
User avatar
PhilMill
Posts: 35
Joined: Tue Aug 28, 2018 9:37 pm

Re: What am I doing wrong, Nav 5

Post by PhilMill »

Thanks, for the replies, so its looking like it doest do any more then, its strange that when its not connected the menu disappears, but when connected the functions dont work but I guess thats to do with not having audio.


Phil
Too many bikes, not enough time!
BoB21
Posts: 744
Joined: Fri Apr 21, 2017 11:38 am
Has liked: 27 times
Been liked: 32 times
Great Britain

Re: What am I doing wrong, Nav 5

Post by BoB21 »

Confused with this thread. Radio should have nothing to do with nav 5!
User avatar
Beagle
Posts: 582
Joined: Mon Jul 16, 2018 7:42 pm

Re: What am I doing wrong, Nav 5

Post by Beagle »

Tried mine today with Nav 6 and the wheel does nothing unless Nav is selected on the main screen. Not got factory Audio.
BoB21
Posts: 744
Joined: Fri Apr 21, 2017 11:38 am
Has liked: 27 times
Been liked: 32 times
Great Britain

Re: What am I doing wrong, Nav 5

Post by BoB21 »

Nav needs to be selected. Scroll down to zoom flick right
User avatar
Beagle
Posts: 582
Joined: Mon Jul 16, 2018 7:42 pm

Re: What am I doing wrong, Nav 5

Post by Beagle »

Just to clarify, Is thought that with the map displayed on the Nav and riding along merrily without the Nav selected on the bikes display the wheel gizmo will change the Nav screen page?

User avatar
PhilMill
Posts: 35
Joined: Tue Aug 28, 2018 9:37 pm

Re: What am I doing wrong, Nav 5

Post by PhilMill »

To clarify, I have the Nav selected and the screen shows zoom out, zoom in and pages, but when the zoom is highlighted and I flick the wheel nothing happens, the only thing that does anything is the display off function, then does what it say, off or on.


Phil
Too many bikes, not enough time!
BoB21
Posts: 744
Joined: Fri Apr 21, 2017 11:38 am
Has liked: 27 times
Been liked: 32 times
Great Britain

Re: What am I doing wrong, Nav 5

Post by BoB21 »

Okay it seems your doing it right afraid it seems a trip to dealer is in order.
guest4915

Re: What am I doing wrong, Nav 5

Post by guest4915 »

Sethmopp wrote: Apparently it doesn't have the connectivity on the RT that it does on the GS, however, if you have the audio package fitted then it does seem to work. I don't have the audio on mine so lost connectivity.

It shouldn't affect the actual connectivity. The only anomaly with having the radio option on the RT is you gain the 'MYMotorcyle' app on the Sat Nav, which you always get on the GS. Why this should be is anyone's guess.
Blade BMW told me a year ago that BMW were preparing a software update to include the App for all RTs. However, since the demise of Blade BMW, I mentioned it to Cotswold BMW who reckoned Blade were just telling me what I wanted to hear ::) 
User avatar
CliveJ
Posts: 20
Joined: Thu Aug 09, 2018 11:54 am
Bike Model and Year: R1200rt lc. 2014
Great Britain

Re: What am I doing wrong, Nav 5

Post by CliveJ »

I may be barking up the wrong tree as I own the 6 but have you got the sat nav "Safe Mode" turned off because if it is on it will not allow you to undertake some tasks whilst moving & this includes the use of the scroll wheel. 
Post Reply