Denali CANSmart with D4's and Dm's and brake light issue

General discussion of the BMW R1200RT/R1250RT
Post Reply
User avatar
Rwslater
Posts: 63
Joined: Sat Nov 28, 2015 8:28 pm
Location: Pennsylvania
United States of America

Denali CANSmart with D4's and Dm's and brake light issue

Post by Rwslater »

I installed the Denali CANsmart controller, a set of D4's and DM's and the brake light.  Everything worked perfectly on an 1800 mile ride last week.  Today I turn the power on to move the windshield up to wash the bike (I hope they change this in the newer models where you have to leave the power on to keep the windshield up-just seems stupid) and all 4 of the LED's were flickering.  A friend of mine has the same setup as mine and his did the same thing after they were installed for about a month.  He spoke to twisted throttle and did some diagnosing and nothing worked. So they sent him replacement parts.  He installed all the new parts, CANsmart first, no change, wires, no change, when he put on the new D4's it took care of the problem.
So when I talked to twisted throttle they wanted me to switch the wires at the controller for the light sets and I did and it made no difference.  The CANsmart Is updated with the new firmware, and I saw on another forum to switch to the two wire setup with the computer hooked up, and that didn't help either.  Twisted throttle is sending me new D4's. Hope it works.
Has anyone else installed the Denali CANsmart with the D4's and had a similar issue? 


Thanks in advance
Ron
User avatar
michaelc2710
Posts: 520
Joined: Wed Feb 22, 2017 11:31 pm
Location: Greater Manchester
Has liked: 10 times
Been liked: 29 times
Great Britain

Re: Denali CANSmart with D4's and Dm's and brake light issue

Post by michaelc2710 »

Hi Ron


Have you tried turning the brightness up slightly using the 'wonder wheel' on the handle bars.
IF for some reason the setting has changed and the D4's are set on the lowest brightness they can flicker.


Hope this helps

User avatar
Rwslater
Posts: 63
Joined: Sat Nov 28, 2015 8:28 pm
Location: Pennsylvania
United States of America

Re: Denali CANSmart with D4's and Dm's and brake light issue

Post by Rwslater »

I had mine set on level #2 with the low beam on, and #10 when I go to high beam.  My buddy has his set on #4 with low beam.  Both bikes flickered.  When I switch to high beam the D4's don't flicker as far as I can tell. 
User avatar
Rwslater
Posts: 63
Joined: Sat Nov 28, 2015 8:28 pm
Location: Pennsylvania
United States of America

Re: Denali CANSmart with D4's and Dm's and brake light issue

Post by Rwslater »

Michael, what is strange is before the 1800 mile trip, all the lights worked perfectly with no issues. 
User avatar
michaelc2710
Posts: 520
Joined: Wed Feb 22, 2017 11:31 pm
Location: Greater Manchester
Has liked: 10 times
Been liked: 29 times
Great Britain

Re: Denali CANSmart with D4's and Dm's and brake light issue

Post by michaelc2710 »


Have you checked your earthing point, I took my live from the positive tail (remote post) and just earthed from a bolt on the frame, as the battery on my 1250RT was a nightmare to get out compared to the 1200rt I had it all on before.
Failing that sorry I can't be of anymore help.
User avatar
Rwslater
Posts: 63
Joined: Sat Nov 28, 2015 8:28 pm
Location: Pennsylvania
United States of America

Re: Denali CANSmart with D4's and Dm's and brake light issue

Post by Rwslater »

Yes ground wire is connected to the remote post. 
Thanks
StephenT
Posts: 1
Joined: Sun Aug 26, 2018 2:22 pm

Re: Denali CANSmart with D4's and Dm's and brake light issue

Post by StephenT »

I fitted a CanSmart RAG-SMK-R1200RT kit from Nippy Norman which worked well until this week.  Both DR1 LEDs now flicker constantly.
User avatar
Rwslater
Posts: 63
Joined: Sat Nov 28, 2015 8:28 pm
Location: Pennsylvania
United States of America

Re: Denali CANSmart with D4's and Dm's and brake light issue

Post by Rwslater »

I had them reorder and send me two new D4 lights because that is what fixed a buddy of mine's 1200GS when his started flickering.  I received the new D4's and installed them and they have been fine ever since. No flickering! 
Post Reply